» Off-"Flitsservice" » Auto's » Dashcam info   

Postingstijd interval gedetecteerd van 482.2 dagen. Deze pagina bevat dus deels relatief oude berichten.


 Pagina 1 van 1  [ 23 berichten ]

Pro
 Bericht 
Wanneer HD-beelden in de VisionDrive-software geëxporteerd worden, heeft de audio de nare neiging om uit sync te gaan lopen bij het beeld.
Ik heb op dit forum gezocht naar een makkelijke manier om dit te corrigeren, maar ik vond niks geautomatiseerds. Misschien heb ik niet goed gezocht?
Ik ben vervolgens zelf op zoek gegaan en heb voor mij de ideale manier gevonden. Het corrigeren van de framerate kost nu maar luttele seconden :)

Door gebruik te maken van AviDemux2, kan de framerate van de beelden worden aangepast, zonder opnieuw te hoeven encoderen. Het mooie is dat deze tool ook over goede commandline opties beschikt. Daardoor hoef ik nu alleen nog maar het originele filmbestand op een batchbestand te slepen en alles gaat automatisch.

Voorbereiding:

Gebruik:
  • Sleep een geëxporteerd filmbestand op de batch file. Nu wordt er een kopie gemaakt van het bestand, met als achtervoegsel "_InSync.avi".

Hieronder nog even het voorbeeld van het batchbestand als je hem liever zelf maakt:
Code:
@echo on
%~d1
CD "%~dp1"
"d:\avidemux2\avidemux2_cli.exe" --force-unpack --load "%~1" --video-codec COPY --output-format AVI --audio-codec COPY --fps 14,645 --save "%~1-InSync.avi" --quit
pause


Bij mij werkt een framerate van 14,645 prima. Ik weet niet hoe dit voor andere systemen geldt. Ik zou zeggen, test het eens en vermeld je ervaringen in dit topic.

Succes!

Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.
Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.
Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.
Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.
Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.

Pro
 Bericht 
Dave schreef:
Heb dus toevallig van de week zitten experimenteren met YAAI (en Mencoder).. Leuk tooltje om snel de correcte framerate te vinden alleen wijzigt dat tooltje iets wat alleen WMP/Vimeo accepteert.


Ik lees dat YAAI ook een commandline heeft (of krijgt in v2...). Misschien ook wel iets mee mogelijk...

Morbid Angel schreef:
Edit 2: de batchfile werkt met de 64-bit versie. De 14.645 fps is bij mij helaas niet vast (wisselt per filmpje van 10 ~ 15fps , die zal ik per filmpje wel moeten aanpassen.


Hmmm, dat is vervelend. Zou mooi zijn als we dat ook automatisch konden laten berekenen in de commandline :roll:

Morbid Angel schreef:
Yep, net één van mijn eerste filmpjes door de batchfile heen gedraaid en geüpload, deze speelt prima af.
Edit: alleen dus niet in VirtualDub, Youtube en Winamp doen het wel.


Als je de schakeloptie '--force-unpack' eruit haalt, krijg je tijdens het proces nog een vraag of je de bitstream wilt unpacken. Als je dan voor nee kiest, is het bestand wel in VirtualDub uit te lezen. Ik denk dat Youtube e.d. dan ook gewoon nog wel moet werken. We komen er wel! :P

Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.
Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.
Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.

Pro
 Bericht 
We kwamen een paar replies boven jouw vraag erachter dat je dat kan oplossen door de parameter '--force-unpack' niet meegeeft. Dit zorgt er wel voor dat tijdens het omzetten een vraag wordt gesteld, die je met nee moet beantwoorden. Daarna, is hij prima afspeelbaar!

Succes!

Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.
Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.

Pro
 Bericht 
Bij mij staat avidemux2_cli.exe op d:\avidemux2\avidemux2_cli.exe. Maar afhankelijk van waar jij avidemux2 hebt uitgepakt, moet je daarnaar verwijzen, zodat de applicatie aangeroepen kan worden. Bijvoorbeeld: C:\program files (x86)\AviDemux2\avidemux2_cli.exe.

Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.

Pro
 Bericht 
Yup, de .bat file wijzigen in kladblok.

Vergeet je niet de aanpassing tegen het schokken zoals die hierboven stond mee te nemen? Hieronder nog maar even quoten:

Citaat:
Als je de schakeloptie '--force-unpack' eruit haalt, krijg je tijdens het proces nog een vraag of je de bitstream wilt unpacken. Als je dan voor nee kiest, is het bestand wel in VirtualDub uit te lezen. Ik denk dat Youtube e.d. dan ook gewoon nog wel moet werken. We komen er wel!


Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.
Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.

Pro
 Bericht 
Het is een beetje spelen met de instelling '--fps 14,645'. Deze kun je hoger of lager zetten. Moet je even kijken welke fps voor jou het beste werkt. Ik heb het idee dat dit afhangt van de snelheid van je pc. Bij het encoderen in VDAnalyzer kan dit natuurlijk sneller of langzamer zijn gegaan.

Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.

Pro
 Bericht 
Die fouten komen mij niet bekend voor.
Hoe is het resultaat van het filmpje? Is die wel oke?

Ik zie wel in je log dat er gewerkt wordt met de LAVF de/encoder. Mogelijk wordt die ook gebruikt bij het encoden in VDAnalyzer en ziet jouw opgeleverde avi-file er dus anders uit dan bij mij. Heb je die xvid-codec die op de Vision Drive staat geïnstalleerd?

Deze persoon wordt in dit onderwerp genegeerd. Toon dit bericht.

Pro
 Bericht 
Mooi werk! Bedankt ook voor het melden hoe je het hebt op weten te lossen!

 Pagina 1 van 1 [ 23 berichten ] 


Wie is er online

Leden op dit forum: Geen geregistreerde gebruikers en 1 gast


Je mag geen nieuwe onderwerpen in dit forum plaatsen
Je mag niet antwoorden op een onderwerp in dit forum
Je mag je berichten in dit forum niet wijzigen
Je mag je berichten niet uit dit forum verwijderen
Je mag geen bijlagen toevoegen in dit forum

Zoek…         
privacy policy